CNAP: Semester 2 ver. 2.1 - YSU Department of Computer

Download Report

Transcript CNAP: Semester 2 ver. 2.1 - YSU Department of Computer

CNAP: Semester 2 ver. 2.1
Introduction to Router Configurations
Or, “What The Heck Does That Line Do?”
Bob Meyers, CCNA, CCAI
Youngstown State University
Sept. 2000
Semester 2 Objectives
Configure
all routers and PC’s given the
teacher topology.
Build and configure a complete
network given an IP addressing
space and a topology.
Troubleshoot connectivity problems
in both topologies.
RE Meyers, CCNA, CCAI
2
Learning Problem
It’s
hard to accomplish the objectives if you
do not understand what each line of a
running configuration means to network
connectivity.
RE Meyers, CCNA, CCAI
3
Learning Problem Solution
Look
at each line of a properly configured
CNAP Teaching Topology.
Determine how each line contributes to the
complete connectivity of the working
Teacher Topology.
Examine what IOS programming commands
enable the running configuration results.
RE Meyers, CCNA, CCAI
4
Teaching Topology
Don’t
even think about starting a project
without a clean copy of the topology and
interface charts!
Unless
you enjoy getting
totally lost ...
RE Meyers, CCNA, CCAI
5
How to use the presentation
 Each
slide lists lines of the configuration, with an explanation
next to it in black font.
 Some of the configuration commands listed are not covered in
the CCNA.
 Those
lines will be highlighted in blue, and can be ignored for now.
 A brief description will be given of those lines for the curious.
 The
“notes view” of each slide has the configuration listed
and line numbered.
 Line
numbering does not occur when programming or viewing the
configuration. It is done here for convenience!
RE Meyers, CCNA, CCAI
6
Configuration for Router Lab-A
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Lab-A
!
enable secret 5
$1$qBZW$2VeiHaAEdG89KRwYu3LEF1
!
no ip subnet-zero
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
Line separator/comments
The Cisco IOS version in use.
Timestamps debugging messages
Time since system reboot.
Stops encryption of ALL passwords.
Line separator; comments
Name given to the router.
Separator
Encrypted enable mode password.
Separator
Disables ability to recover
addresses lost when sub netting.
RE Meyers, CCNA, CCAI
7
Lab-A Configuration (cont.)
12.
ip host Lab-B 201.100.11.2 219.17.100.1 199.6.13.1
13.
ip host Lab-C 199.6.13.2 223.8.151.1 204.204.7.1
14.
ip host Lab-D 204.204.7.2 210.93.105.1
15.
ip host Lab-E 210.93.105.2
16.
ip host Lab-A 192.5.5.1 205.7.5.1 201.100.11.1
17.
!
12–16. “DNS” resolution.
Resolves the router
name to the IP
addresses that are
configured on that
router’s interfaces.
Allows you to just type
in the name of the
router when using
telnet. The router
compares the name to
this table and routes
the telnet session
according to the IP’s
listed here.
17. Separator
RE Meyers, CCNA, CCAI
8
Lab-A Configuration (cont.)
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
!
!
interface Ethernet0
ip address 192.5.5.1
255.255.255.0
no ip directed-broadcast
no shutdown
!
interface Ethernet1
ip address 205.7.5.1
255.255.255.0
no ip directed-broadcast
no shutdown
!
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
Separator
Separator
Configure the first Ethernet port, E0
Assign IP and subnet mask to Ethernet
port E0
All IP directed broadcasts are dropped
Forces the port to stay open/up.
Separator
Configure the second Ethernet port, E1
Assigns IP and Subnet mask to Ethernet
port E1
All IP directed broadcasts are dropped
Forces the port to stay open/up.
Separator
RE Meyers, CCNA, CCAI
9
Lab-A Configuration (cont.)
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
interface Serial0
ip address 201.100.11.1
255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 56000
no shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
Configure first serial port S0
Assigns an IP and subnet mask to serial
port S0
All IP directed broadcasts are dropped.
Disables IP multicast fast switching.
Disables S0 traffic priority management.
Sets S0 clock rate at 56KBps
Keeps S0 up. Prevents shutdown.
Separator
Configure second serial interface S1.
No layer 3 address is assigned.
All IP directed broadcasts are dropped.
S1 is administratively forced to shutdown.
Separator
RE Meyers, CCNA, CCAI
10
Lab-A Configuration (cont.)
43.
44.
45.
46.
47.
48.
49.
router rip
network 192.5.5.0
network 201.100.11.0
network 205.7.5.0
!
no ip classless
!
Starts RIP routing protocol
44 – 46. Tells the router to send
and accept RIP updates to and
from the IP networks listed.
47.
Separator
48.
Discards packets for a subnet
that fall within its
subnetwork addressing scheme
if there is no such subnet
number in the routing table
and there is no network
default route.
49.
Separator
43.
RE Meyers, CCNA, CCAI
11
Lab-A Configuration (cont.)
50.
51.
52.
53.
54.
55.
56.
57.
58.
59.
60.
!
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
50.
51.
52.
53.
54.
55.
56.
57.
58.
59.
60.
Line separator
Configure the console port.
Create the password “cisco”
Assign it to the console login
VTY sessions only on this port.
Configure the first aux port.
Allow 5 simultaneous telnet sessions.
Create the password “cisco”
Assign it to Telnet login sessions.
Separator
End of configuration.
RE Meyers, CCNA, CCAI
12
“Plain English” Line by Line Explanation.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
Separator
Cisco IOS version currently in use.
Put a time on each debug message.
Start a timer to show how long the router’s
been running.
Don’t encrypt all the passwords, just do the
ones I select as secret.
Separator
The name given to the router.
Separator (again)
The privileged mode password after it’s
been encrypted for secrecy.
Pay attention – this is a line separator.
Subnet the way we learned it, and lose the
first and last subnets.
These are the IP addresses that are used by
a router named Lab-B
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
These are the IP’s used by the router
named Lab –C
Guess who uses these IP addresses?
Guess again.
Guess one more time.
I’m not telling you again about the
“separator.”
I mean it.
I really mean it!
Time to configure the first Ethernet port,
E0.
Here’s the IP and the subnet for the port.
Stop all IP broadcasts right here!
Please don’t let E0 shutdown make me
crazy wondering why I can’t connect.
RE Meyers, CCNA, CCAI
13
“Plain English” Line by Line Explanation.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
I refuse to answer.
Get the second ethernet port, E1,
ready for configuration.
Give E1 this IP and subnet address.
Stop all IP broadcasts from entering
this port from the LAN.
Don’t shutdown this port. Please?
See 24.
Get the first serial port, S0, ready for
configuration.
Assign this IP and subnet mask to S0.
Stop those @##$* IP broadcast
messages!
Do not allow fast switching –
whatever the heck it is anyway.
34.
35.
36.
37.
38.
39.
40.
41.
Don’t use the fancy packet management
system on this interface, ‘cause I don’t know
how it works – yet.
S0 is DCE connection, so it needs to provide
the clock rate. 56,000 Bps sounds like a good
number.
If this interface shuts down I’ll lose my link to
all the other routers. So don’t.
See 29.
Let’s configure the second serial interface, S1.
Hey if it’s second, why is it labeled S1?
I’m not using it so don’t give it an IP.
Stop those pesky IP broadcasts again. Even
though I’m still not using this port.
Not using it you say? Then shut it down.
RE Meyers, CCNA, CCAI
14
“Plain English” Line by Line Explanation.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
You talking to me?
This router will now use RIP as the routing
protocol.
Accept, and send routing updates, to and
from this network address.
Do it on this network address, too.
Ditto.
Still means what it did 5 slides ago!
There’s a way to recover the 2 lost
addresses when sub netting, but don’t use
it till we learn it.
Running out of clever retorts for this
sucker.
Ask one more time and I’m outta here.
Configure the console port.
Make “cisco” a password.
53.
54.
55.
56.
57.
58.
59.
60.
Take the password “cisco” and make it the
login challenge when anybody connects to
the console port.
There are other ways to use the console
port, but let’s make a terminal program the
only thing the port will recognize.
Open the AUX port for configuration. But
don’t do anything to it.(?)
Configure all incoming Telnet sessions,
and limit them to 5 simultaneous
connections (0, 1, 2, 3, 4).
Create the password “cisco.” You can use
any other alphanumeric string if you want.
Use “cisco” as the password for all
incoming Telnet login challenges.
I warned you, didn’t I?
Outta here.
RE Meyers, CCNA, CCAI
15
The other router configurations
can be analyzed the exact same
way. Try it for yourself!
RE Meyers, CCNA, CCAI
END
16