network 10.0.0.0 0.255.255.255 area 0

Download Report

Transcript network 10.0.0.0 0.255.255.255 area 0

Sybex CCENT 100-101
Chapter 9: Open Shortest Path First
(OSPF)
Instructor & Todd Lammle
Chapter 9 Objectives
• The CCENT Topics Covered in this chapter
include:
• IP Routing Technologies
– Configure and verify OSPF (single
area)
•
•
•
•
Benefit of single area
Configure OSPF v2
Router ID
Passive interface
2
Open Shortest Path First (OSPF)
• OSPF uses Dijkstra algorithm to construct
a shortest path tree
• Then, OSPF populates the routing table
with the resulting shortest path
• It supports multiple, equal-cost routes to
the same destination
OSPF best feature summary
OSPF vs. RIPv2 vs. RIPv1
Figure 9.1: OSPF design example.
An OSPF hierarchical design minimizes routing table entries and keeps the impact
of any topology changes contained within a specific area.
OSPF terminology
• Link
– A link is a network or router interface assigned to any given
network
– When an interface is added to the OSPF process, it’s considered
to be a link
– This link has up or down state information and one or more IP
addresses
• Router ID
– RID is an IP address used to identify the router
– The highest IP address of all configured loopback interfaces is
selected as RID
– Or the highest IP address of all active physical interface is
selected as RID
OSPF terminology 2
• Neighbor
– Two router that are connected a PPP link
– OSPF neighbors must have the same
configuration to establish a neighborhood
relationship
•
•
•
•
Area ID
Stub area flag
Authentication password (if using one)
Hello and Dead intervals
OSPF terminology 2
• Adjacency
– A relationship between 2 OSPF routers that permits
direct exchange of route updates
– Not all neighbors become adjacency
• Designated Router (DR)
– A DR is elected whenever OSPF routers are
connected to the same broadcast network
• To minimize the number of adjacencies formed
• To publicize received routing information to and from the
remaining routers
– The router with the highest priority is the winner
OSPF terminology 3
• Backup Designated Router (BDR)
– A hot standby for the DR
– BDR receives OSPF updates from all adjacent
routers but doesn’t disperse Link State
Advertisement(LSA) updates
• Hello protocol
– Provides dynamic neighbor discovery and maintain
neighbor relationships
– Hello packets and LSAs build and maintain the
topological database
– Hello packets are addressed to multicast address:
224.0.0.5
OSPF terminology 4
• Neighborship database
– A list of all OSPF routers for which Hello packets have
been seen
– A variety of details are maintained on each router in
the DB
• Topological database
– Contains information from all of the LSA packets
– The information is used as input to Dijkstra algorithm
OSPF terminology 5
• OSPF areas
– A grouping of contiguous networks and routers
– Enhances scalability of OSPF
– All of the routers within the same area have the same
topology table
– All routers in the same area share a common area ID
– The area ID is associated with specific interfaces on
the router
• A router can be a member of multiple areas at a time
– Area 0 is the backbone area
• Broadcast (multi-access)
– In OSPF, a DR and BDR must be elected for each broadcast
network
OSPF operation
• OSPF operation is basically divided into
three categories:
– Neighbor and adjacency initialization
• Hello protocol
– LSA flooding
– SPF tree calculation
Figure 9.2: The Hello protocol
The Hello protocol is used to discover neighbors, establish adjacencies,
and maintain relationships with other OSPF routers. Hello packets are
periodically sent out each enabled OSPF interface and in environments that
support multicast.
Hello packets are periodically sent out of each enabled OSPF interface
and in environments that support multicast
LSA flooding
• The method of OSPF uses to share routing
information
• LSA information containing link-state data is
shared with all OSPF routers within an area
• A network topology is created from the LSA
updates
• Efficient flooding is achieved through the use of
a reserved multicast address
Table 9.2: LSA update multicast
addresses
Network Type
Multicast Address
Description
Point-to-point
224.0.0.5
AllSPFRouters
Broadcast
224.0.0.6
AllDRouters
Point-to-multipoint
NA
NA
The network type determines the multicast address used for sending updates.
Table 9.2 contains the multicast addresses associated with LSA flooding. Pointto-multipoint networks use the adjacent router’s unicast IP address.
Configuring OSPF
• Enabling OSPF
• Configuring OSPF areas
Enabling OSPF
The easiest and also least scalable way to configure OSPF is to
just use a single area. Doing this requires a minimum of two
commands.
The first command is used to activate the OSPF routing process
is as follows:
Router(config)#router ospf ?
<1-65535> Process ID
A value in the range from 1 to 65,535 identifies the OSPF process ID.
Configuring OSPF Areas
Here’s an example of basic OSPF basic
configuration for you, showing our 2nd minimum
command needed, the network command:
Router#config t
Router(config)#router ospf 1
Router(config-router)#network 10.0.0.0 0.255.255.255 area ?
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D
OSPF area ID in IP address format
Router(config-router)#network 10.0.0.0 0.255.255.255 area 0
The areas can be any number from 0 to 4.2 billion. Don’t get these numbers
confused with the process ID, which ranges from 1 to 65,535.
Configuring OSPF Areas 2
• The network command has 2 arguments
– Network number (10.0.0.0)
– Wildcard mask (0.255.255.255)
• Always one less than the block size
– OSPF will use this command to find any
interface on the router configured in the
10.0.0.0 network and will place any interface it
finds into area 0
Wildcard Example
In this scenario, you have a router with these four subnets connected to four different
interfaces:




192.168.10.64/28
192.168.10.80/28
192.168.10.96/28
192.168.10.8/30
All interfaces need to be in area 0, so it seems to me the easiest configuration would
look like this:
Test#config t
Test(config)#router ospf 1
Test(config-router)#network 192.168.10.0 0.0.0.255 area 0
Let’s create a separate network statement for each interface
using the subnet numbers and wildcards. Test#config t
Test(config)#router ospf 1
Test(config-router)#network
Test(config-router)#network
Test(config-router)#network
Test(config-router)#network
192.168.10.64 0.0.0.15 area 0
192.168.10.80 0.0.0.15 area 0
192.168.10.96 0.0.0.15 area 0
192.168.10.8 0.0.0.3 area 0
Figure 9.3: Sample OSPF wildcard
configuration
Here’s the OSPF configuration using wildcards:
Lab_A#config t
Lab_A(config)#router ospf 1
Lab_A(config-router)#network 192.168.10.64 0.0.0.7 area 0
Lab_A(config-router)#network 10.255.255.80 0.0.0.3 area 0
The Lab_A router is using a /29, or 255.255.255.248, mask on the Fa0/0 interface. This is
a block size of 8, which is a wildcard of 7. The G0/0 interface is a mask of
255.255.255.252—block size of 4, with a wildcard of 3. Notice that I typed in the subnet
number, not the interface IP address.
Figure 9.4: Our new network layout
Corp router’s configuration
0.0.0.0 means that the IP address must precisely match each octet
SF router’s configuration
LA router’s configuration
Figure 9.5: Adding a non-OSPF
network to LA router
We can use the same command that we did under that routing process here as well!
Take a look:
LA(config)#router ospf 100
LA(config-router)#passive-interface fastEthernet 0/1
I added this command as an example on interface Fa0/1, which happens to be an
interface we’re not using in this network because I want OSPF to work on my other
router’s interfaces.
Corp router’s configuration cont.
• Configure Corp router to advertise a default route to the SF and LA
routers
OSPF and Loopback Interfaces
• Loopback interfaces are logical interfaces
– Vital to configure loopback interfaces when
using OSPF
– Ensure that an interface is always active and
available for OSPF process
– Come in handy for diagnostic purposes
• The highest IP address of any logical
interface becomes the router’s RID
Figure 9.6: OSPF router ID (RID)
The RID is not only used to advertise routes, it’s also used to elect the designated
router (DR) and the backup designated router (BDR). These designated routers create
adjacencies when a new router comes up and exchanges LSAs to build topological
databases.
Configuring Loopback Interfaces
Configuring Loopback Interfaces cont.
• Any IP address can be used as long as the
addresses are never the same on any two
routers
• The /32 mask is called a host mask and works
fine for loopback interfaces
– Also allows us to save subnets
• Create logical interfaces before you start OSPF
routing
– The loopback interface would always become your
RID
Verifying OSPF Configuration
• Show ip route, show ip int brief
• Show ip ospf
– Displays OSPF information for one or all OSPF processes running on a
router
• Show ip ospf database
– Gives you information about the number of routers in the AS plus the
neighboring router’s ID—the topology database
• Show ip ospf interface
– Reveals all interface related information
• Show ip ospf neighbor
– Summarizes the pertinent OSPF information regarding neighbors and the
adjacency state
• Show ip protocols
– Provides an overview of the actual operation of all currently running protocols
Written Labs and Review
Questions
– Read through the Exam Essentials
section together in class
– Open your books and go through all the
written labs and the review questions.
– Review the answers in class.
34