show ip route

Download Report

Transcript show ip route

Chapter 7
RIP version 2
CIS 82 Routing Protocols and Concepts
Rick Graziani
Cabrillo College
[email protected]
Last Updated: 4/7/2008
Note
 My web site is www.cabrillo.edu/~rgraziani.
 For access to these PowerPoint presentations and other
materials, please email me at [email protected].
2
For further information
 This presentation is an
overview of what is
covered in the
curriculum/book.
 For further explanation
and details, please read
the chapter/curriculum.
 Book:
 Routing Protocols
and Concepts
 By Rick Graziani and
Allan Johnson
 ISBN: 1-58713-206-0
 ISBN-13: 978-58713206-3
3
Topics
 RIPv1 Limitations
 RIPv1: Topology Limitations
 RIPv1: Discontiguous
Networks
 RIPv1: No VLSM Support
 RIPv1: No CIDR Support
 Configuring RIPv2
 Enabling and Verifying RIPv2
 Auto-Summary and RIPv2
 Disabling Auto-Summary in
RIPv2
 Verifying RIPv2 Updates
 VLSM and CIDR
 RIPv2 and VLSM
 RIPv2 and CIDR
 Verifying and Troubleshooting
RIPv2
 Verification and
Troubleshooting Commands
 Common RIPv2 Issues
 Authentication
4
RIPv1 Limitations
 RIPv1: Topology Limitations
 RIPv1: Discontiguous Networks
 RIPv1: No VLSM Support
 RIPv1: No CIDR Support
Note on Classful Routing Protocols, RIPv1 limitations
 The first part of this presentation discusses the limitations of classful
routing protocols such as RIPv1.
 RIPv1 is used as an example, so we can see how RIPv2 a classless
routing protocol does not have these same limitations.
 Classful routing protocols have three major limitations:
 Does not support discontiguous networks.
 Does not support VLSM
 Does not support CIDR
 Instead of just “memorizing” these facts, we will demonstrate and
“understand” why a classful routing protocol has these limitations.
6
RIPv1: Distance Vector, Classess Routing Protocol
 RIP Version 2 (RIPv2) is defined in RFC 1723.
 RIPv2 is the first classless routing protocol discussed in this book.
 RIPv2 has lost popularity when compared to other routing protocols
such as EIGRP, OSPF and IS-IS.
 RIPv2, it is ideal for explaining the differences between a classful
routing protocol (RIPv1) and a classless routing protocol (RIPv2).
7
RIPv1 and RIPv2
 RIPv2 is actually an enhancement of RIPv1’s features and extensions
rather than an entirely new protocol.
 Next-hop addresses included in the routing updates
 Use of multicast addresses in sending updates
 Authentication option available
 Both versions of RIP share the following features and limitations:
 Use of hold-down and other timers to help prevent routing loops
 Use of split horizon and split horizon with poison reverse to also
help prevent routing loops
 Use of triggered updates when there is a change in the topology for
faster convergence
 Maximum hop count of 15 hops, with the hop count of 16 signifying
an unreachable network
8
RIPv1 Limitations
172.30.0.0
/16
172.30.0.0
/16
 In a discontiguous network, a classful major network address, such as
172.30.0.0/16, is separated by one or more other major networks.
 172.30.0.0/16 is divided by the networks:
 209.165.200.228/30
 209.165.200.232/30
 Classful routing protocols do not include enough routing information to
route properly for discontiguous networks.
9
Summary Route
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
172.30.0.0/16
172.30.0.0
/16
 R2: static summary route to the 192.168.0.0/16 network.
 Redistribution - Inject static route(s) into routing protocol updates.
 For now, this summary route will cause problems with RIPv1 because:
 192.168.0.0/16 is not a major classful address (192.168.0.0/24)
 Includes all the /24 versions of 192.168.0.0/16
10
VLSM
172.30.0.0/16
172.30.0.0
/16
 R1 and R3 contain VLSM networks.
 Both R1 and R3 are configured with /24 subnets of the 172.30.0.0/16
network.
 R3: 172.30.200.0/24 subnetted again, using the first 4 bits for subnets and
the last 4 for hosts.
 172.30.200.16/28 and 172.30.200.32/28
11
VLSM
 R3: 172.30.200.0/24 subnetted again, using the first 4 bits for
subnets and the last 4 for hosts.
 172.30.200.16/28 and 172.30.200.32/28
12
Private Addresses and Cisco Example Addresses
RFC 1918 Private Addresses
Cisco Example Addresses
 We use RFC 1918 and Cisco Example addresses for all topologies.
13
Loopback Interfaces
172.30.0.0/16
172.30.0.0
/16
 Loopback interface
 Software-only interface
 Used to emulate an interface.
 Can be assigned an IP address.
 Specific purposes with some routing protocols such as OSPF (later)
 A loopback interface can be:
 pinged
 subnet advertised in routing updates.
 Ideal for simulating multiple networks attached to the same router.
14
RIPv1 Topology Limitations
R1(config)# router rip
R1(config-router)# network 172.30.0.0
R1(config-router)# network 209.165.200.0
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
R2(config-router)# network 10.0.0.0
R2(config-router)# network 209.165.200.0
R3(config)# router rip
R3(config-router)# network 172.30.0.0
R3(config-router)# network 209.165.200.0
 RIPv1 configuration for all three routers
15
Static Routes and
Null Interfaces
R2(config)# ip route 192.168.0.0 255.255.0.0 Null0
 CIDR allows route aggregation.
 A single high-level route entry with a subnet mask less than the classful
mask can be used to represent many lowerlevel routes.
 This results in fewer entries in the routing table.
 The static route on R2 is using a /16 mask to summarize all 256 networks
ranging from 192.168.0.0/24 to 192.168.255.0/24.
 For Lab purposes:
 The static summary route 192.168.0.0/16 does not actually exist.
 To simulate this static route, we will use a null interface as the exit
interface.
 You do not need to enter commands to create or configure the null
interface.
 It is always up but does not forward or receive traffic.
 Traffic sent to the null interface is discarded.
16
Route Redistribution
R2(config)# ip route 192.168.0.0
255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
Is static route being sent via RIPv1 with other RIPv1 routes?
 Redistribution involves taking the routes from one routing source and
sending those routes to another routing source.
 Routes can only be redistributed into a dynamic routing protocol.
 Dynamic routing protocol to a different dynamic routing protocol.
 Static routes to a dynamic routing protocol.
 Directly connected networks to a dynamic routing protocol.
 Want R2 to redistribute our static route (192.168.0.0/16) by importing the
route into RIPv1 and then sending it to R1 and R3 using the RIPv1 process.
 We will see whether this is indeed happening, and if not, why not.
17
Verifying and Testing
Connectivity
R2# ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to
!U!.!
Success rate is 60 percent (3/5),
R2# ping 172.30.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to
!U!.!
Success rate is 60 percent (3/5),
R2#
172.30.1.1, timeout is 2 seconds:
round-trip min/avg/max = 28/29/32 ms
172.30.100.1, timeout is 2 seconds:
round-trip min/avg/max = 28/28/28 ms
 Whenever R2 pings any of the 172.30.0.0 subnets on R1 or R3, only
about 50 percent of the pings are successful.
18
Verifying and Testing
Connectivity
X
R1# ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5),round-trip min/avg/max = 28/28/28 ms
R1# ping 172.30.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
 R1 is able to ping 10.1.0.1 but is unsuccessful when attempting to
ping the 172.30.100.1 interface on R3.
19
Verifying and Testing
Connectivity
X
R3# ping 10.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5),round-trip min/avg/max = 28/28/28 ms
R3# ping 172.30.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#
 R3 is able to ping 10.1.0.1 but is unsuccessful when attempting to
ping the 172.30.1.1 interface on R1.
 As you can see, there is an obvious problem when trying to
communicate with the 172.30.0.0 discontiguous subnets.
20
RIPv1: Discontiguous Networks
 Because the subnet mask is not included in the update, RIPv1 and
other classful routing protocols must summarize networks at major
network boundaries.
21
RIPv1:
Discontiguous
Networks
 RIPv1 on both Routers R1 and R3 will summarize their 172.30.0.0
subnets to the classful major network address of 172.30.0.0 when
sending routing updates to R2.
22
Examining the Routing Tables
R2# show ip route
R
C
C
C
S
172.30.0.0/16 [120/1] via 209.165.200.230, 00:00:09, Serial0/0/0
[120/1] via 209.165.200.234, 00:00:11, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 is directly connected, Serial0/0/1
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 is directly connected, FastEthernet0/0
192.168.0.0/16 is directly connected, Null0
 R2 has two equal-cost routes to the 172.30.0.0/16 network.
 R1 and R3 are sending R2 a RIPv1 update for the 172.30.0.0 network
with a metric of 1 hop.
 R2’s routing table only contains the major classful network address of
172.30.0.0 and adds the Class B subnet mask of /16.
23
debug ip rip
R2# debug ip rip
RIP: received v1 update from 209.165.200.230 on Serial0/0/0
172.30.0.0 in 1 hops
RIP: received v1 update from 209.165.200.234 on Serial0/0/1
172.30.0.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(209.165.200.229)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.232 metric 1
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1
(209.165.200.233)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.228 metric 1
 R2 is receiving two 172.30.0.0 equal-cost routes with a metric of 1 hop:
 one route on Serial 0/0/0 from R1 and
 the other route on Serial 0/0/1 from R3.
 Also notice that the subnet mask is not included with the network
address in the update.
24
show ip route
R1# show ip route
C
C
R
C
R
R1#
172.30.0.0/24 is subnetted, 2 subnets
172.30.2.0 is directly connected, Loopback0
172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:16,Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:16, Serial0/0/0
 R1 has its own 172.30.0.0 routes:
 172.30.2.0/24
 172.30.1.0/24.
 R1 does not send R2 those subnets.
 R1 and R3 are boundary routers only sending the summarized 172.30.0.0
 Result, R2 only knows about the 172.30.0.0/16 classful network and is
unaware of any 172.30.0.0 subnets.
25
Determining the mask and network address
 Receiving an Update: Determining subnet mask for routing table
 What is the major classful network address of the receiving interface?
 What is the major classful network address of the network in the routing
update?
 Are they the same major classful network address?
 Yes: Apply subnet mask of the receiving interface for this network
address in the routing table.
 No: Apply classful subnet mask for this network address in the
routing table.
 Sending an Update: Determining whether or not to summarize route sent
 What is the major classful network address of the sending interface?
 What is the major classful network address of the network in the routing
update?
 Are they the same major classful network address?
 Yes: Send subnet network address
 No: Send summary address – the classful network address
26
Example 1
10.0.0.0/8
.1
172.16.0.0/16
.1
192.168.1.0/24
.2
.1
27
Example 1
10.0.0.0/8
172.16.0.0/16
.1
.1
192.168.1.0/24
.2
.1
Apply /8 classful mask
10.0.0.0
Apply /24 classful mask
192.168.1.0
28
Example 2
172.17.0.0/16
.1
172.16.0.0/16
.1
192.168.1.0/24
.2
.1
29
Example 2
172.17.0.0/16
172.16.0.0/16
.1
.1
192.168.1.0/24
.2
.1
Apply /16 classful mask
172.17.0.0
Apply /24 classful mask
192.168.1.0
30
Example 3
172.17.1.0/24
.1
172.16.0.0/16
.1
10.1.1.0/24
.2
.1
31
Example 3
172.17.1.0/24
.1
172.16.0.0/24
.1
10.1.1.0/24
.2
.1
Apply /16 classful mask
172.17.0.0 (summary)
Apply /8 classful mask
10.0.0.0 (summary)
32
Example 4
172.17.1.0/24
.1
172.17.2.0/24
.1
10.1.1.0/24
.2
.1
33
Example 4
172.17.1.0/24
172.17.2.0/24
.1
.1
10.1.1.0/24
.2
.1
Apply /24 interface mask
172.17.1.0
Apply /8 classful mask
10.0.0.0 (summary)
34
Example 5
172.17.1.0/24
.1
172.17.2.0/24
.1
172.17.3.0/24
.2
.1
35
Example 5
172.17.1.0/24
172.17.2.0/24
.1
.1
172.17.3.0/24
.2
.1
Apply /24 interface mask
172.17.1.0
Apply /24 interface mask
172.17.3.0
36
Example 6
172.17.1.0/24
.1
172.16.2.0/24
.1
172.17.3.0/24
.2
.1
37
Example 6
172.17.1.0/24
.1
172.16.2.0/24
.1
172.17.0.0 (Summary)
Apply /16 classful mask
(route not used)
172.17.3.0/24
.2
.1
Apply /16 classful mask
(route not used)
172.17.0.0 (Summary)
38
How Classful Routing
Protocols Determine
Subnet Masks
Apply classful
default mask of /16
172.30.0.0
Apply classful
default mask of /16
172.30.0.0
39
How Classful Routing
Protocols Determine
Subnet Masks
Apply
classful
default
mask of /8
10.0.0.0
10.0.0.0
Apply
classful
default mask
of /8
40
How Classful Routing
Protocols Determine
Subnet Masks
172.30.0.0
172.30.110.0
172.30.200.16
172.30.2.0
172.30.100.0
172.30.1.0
172.30.200.32
VLSM issues: will discuss next
41
RIPv1: No VLSM Support
 Because RIPv1 does not send the subnet mask in routing updates, it
cannot support VLSM.
 The R3 router is configured with the following VLSM subnets, all of
which are members of the Class B network 172.30.0.0/16:
 172.30.100.0/24 (FastEthernet 0/0)
 172.30.110.0/24 (Loopback 0)
 172.30.200.16/28 (Loopback 1)
 172.30.200.32/28 (Loopback 2)
42
RIPv1: No VLSM Support
Added R4 for purposes of this discussion
 When RIPv1 on R3 sends its 172.30.0.0 subnets out its exit
interface FastEthernet 0/0, it will only include those 172.30.0.0
subnets with the same subnet mask as the exit interface.
43
RIPv1: No CIDR Support
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
R2(config-router)# network 10.0.0.0
R2(config-router)# network 209.165.200.0
R2(config-router)# end
R2# show ip route
R
172.30.0.0/16 [120/1] via 209.165.200.230, 00:00:09, Serial0/0/0
[120/1] via 209.165.200.234, 00:00:11, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
C
209.165.200.232 is directly connected, Serial0/0/1
C
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
C
10.1.0.0 is directly connected, FastEthernet0/0
S
192.168.0.0/16 is directly connected, Null0
 We see the static route, let’s see if it is be sent in RIPv1 updates
with the other RIPv1 routes…
44
R1 Routing Table
R1# show ip route
C
C
R
C
R
172.30.0.0/24 is subnetted, 2 subnets
172.30.2.0 is directly connected, FastEthernet0/1
172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:16,Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:16, Serial0/0/0
 Notice that R1 is not receiving this 192.168.0.0/16 route in its RIP
updates from R2
45
debug ip rip
R2# debug ip rip
RIP: received v1 update from 209.165.200.230 on Serial0/0/0
172.30.0.0 in 1 hops
RIP: received v1 update from 209.165.200.234 on Serial0/0/1
172.30.0.0 in 1 hops
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(209.165.200.229)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.232 metric 1
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1
(209.165.200.233)
RIP: build update entries
network 10.0.0.0 metric 1
subnet 209.165.200.228 metric 1
 R2 is not including the 192.168.0.0/16 route in its RIPv1 updates
to either R1 or R3.
46
RIPv1: No CIDR Support
R2(config)# ip route 192.168.0.0 255.255.0.0 null0
R2(config)# router rip
R2(config-router)# redistribute static
 The static route 192.168.0.0 has a /16 mask.
 This is fewer bits than the classful Class C mask of /24.
 RIPv1 and other classful routing protocols cannot support CIDR
routes that are summarized routes with a smaller subnet mask than
the classful mask of the route.
 RIPv1 ignores these supernets in the routing table and does not include
them in updates to other routers.
 This is because the receiving router would only be able to apply the
larger /24 classful mask to the update and not the shorter /16 mask.
 Note:
 If the 192.168.0.0 static route were configured with a /24 mask or
greater, this route would be included in the RIP updates.
 The receiving routers would apply the classful /24 mask to this update.
47
Configuring RIPv2
 Enabling and Verifying RIPv2
 Auto-Summary and RIPv2
 Disabling Auto-Summary in RIPv2
 Verifying RIPv2 Updates
Configuring RIPv2
 Configuring RIPv2 is
similar to configuring
RIPv1, with the addition
of a single RIP
command, version 2.
 Although RIPv2 uses the
same basic
configuration
commands as RIPv1,
the results of using
RIPv2 are different,
allowing both CIDR and
VLSM to be used in the
network.
49
Enabling and Verifying RIPv2
 RIPv2 is defined in
RFC 1723.
 RIPv2 message
format is the subnet
mask field that allows
a 32-bit mask to be
included in the RIP
route entry.
 As a result, the
receiving router no
longer depends on
the subnet mask of
the inbound interface
or the classful mask
when determining the
subnet mask for a
route.
50
Enabling and Verifying RIPv2
R2# show ip protocols
<output omitted>
Default version control: send version 1, receive any version
Interface
Send
Recv
Triggered RIP Key-chain
Serial0/0/0
1
1 2
Serial0/0/1
1
1 2
Automatic network summarization is in effect
<output omitted >
 Default RIPv1: When configuring RIP
 Router only sends RIPv1 messages, it can process both RIPv1 and
RIPv2 messages.
 Ignore the RIPv2 fields in the route entry.
 RIPv2 will ignore RIPv1 updates.
 FYI only: The interface commands ip rip send and ip rip receive
can be used to force compatibility between different versions.
51
Enabling and Verifying RIPv2
R1(config)# router rip
R1(config-router)# version 2
R2(config)# router rip
R2(config-router)# version 2
R3(config)# router rip
R3(config-router)# version 2
 version 2 command is used to modify RIP to use Version 2.
 This command should be configured on all routers in the routing
domain.
52
Enabling and Verifying RIPv2
R2# show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 1 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Redistributing: static, rip
Default version control: send version 2, receive version 2
Interface
Send
Recv
Triggered RIP Key-chain
Serial0/0/0
2
2
Serial0/0/1
2
2
Automatic network summarization is in effect
<output omitted for brevity>
53
Restoring RIP to Version 1
R1(config)# router rip
R1(config-router)# version 1
!or
R1(config)# router rip
R1(config-router)# no version
 Default behavior of RIPv1 can be restored by using either the
(slightly different behaviors in sending and receiving):
 version 1 command
 no version command
 If done, should be configured on all routers.
54
Auto-Summary and RIPv2
R2# show ip route
R
C
C
C
S
172.30.0.0/16 [120/1] via 209.165.200.230, 00:00:28, Serial0/0/0
[120/1] via 209.165.200.234, 00:00:18, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 is directly connected, Serial0/0/1
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 is directly connected, FastEthernet0/0
192.168.0.0/16 is directly connected, Null0
 You still see the summarized 172.30.0.0/16 route with the same
two equal-cost paths.
55
Auto-Summary and RIPv2
R1# show ip route
C
C
R
C
R
R
172.30.0.0/24 is subnetted, 2 subnets
172.30.2.0 is directly connected, Loopback0
172.30.1.0 is directly connected, FastEthernet0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:04,Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/8 [120/1] via 209.165.200.229, 00:00:04, Serial0/0/0
192.168.0.0/16 [120/1] via 209.165.200.229, 00:00:04, Serial0/0/0
 Routers R1 and R3 still do not include the 172.30.0.0 subnets of the
other router.
 The only difference so far between RIPv1 and RIPV2 is that R1 and R3
each have a route to 192.168.0.0/16.
 This route was the (CIDR) static route configured on R2 and redistributed by
RIP.
 What’s happening?
56
Auto-Summary and RIPv2
R1# debug ip rip
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0
(209.165.200.230)
RIP: build update entries
172.30.0.0/16 via 0.0.0.0, metric 1, tag 0
<output omitted for brevity>
RIP: received v2 update from 209.165.200.229 on Serial0/0/0
10.0.0.0/8 via 0.0.0.0 in 1 hops
192.168.0.0/16 via 0.0.0.0 in 1 hops
209.165.200.232/30 via 0.0.0.0 in 1 hops
 Notice that RIPv2 is sending both the network address and
subnet mask.
 Notice that the route sent is the summarized classful network
address, 172.30.0.0/16
 not the individual 172.30.1.0/24 and 172.30.2.0/24 subnets.
57
Auto-Summary and RIPv2
R1# show ip protocols
Routing Protocol is “rip”
<output omitted>
Default version control: send version 2, receive version 2
Interface
Send
Recv
Triggered RIP Key-chain
FastEthernet0/0
2
2
FastEthernet0/1
2
2
Serial0/1/0
2
2
Automatic network summarization is in effect
 By default, RIPv2 automatically summarizes networks at major
network boundaries, just like RIPv1.
 Both R1 and R3 routers are still summarizing their 172.30.0.0
subnets to the Class B address of 172.30.0.0 when sending updates
out their interfaces on the 209.165.200.228 and 209.165.200.232
networks, respectively.
58
Disabling Auto-summary in RIPv2
R2(config)# router rip
R2(config-router)# no auto-summary
R3(config)# router rip
R3(config-router)# no auto-summary
R1(config)# router rip
R1(config-router)# no auto-summary
R1# show ip protocols
<output omitted>
Automatic network summarization is not in effect
<output omitted>
 To modify the default RIPv2 behavior of automatic summarization,
use the no auto-summary command
59
Verifying RIPv2 Updates
R2# show ip route
R
R
R
R
R
R
C
C
C
S
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
172.30.200.32/28 [120/1] via 209.165.200.234, 00:00:09, Serial0/0/1
172.30.200.16/28 [120/1] via 209.165.200.234, 00:00:09, Serial0/0/1
172.30.2.0/24 [120/1] via 209.165.200.230, 00:00:03, Serial0/0/0
172.30.1.0/24 [120/1] via 209.165.200.230, 00:00:03, Serial0/0/0
172.30.100.0/24 [120/1] via 209.165.200.234, 00:00:09, Serial0/0/1
172.30.110.0/24 [120/1] via 209.165.200.234, 00:00:09, Serial0/0/1
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 is directly connected, Serial0/0/1
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 is directly connected, FastEthernet0/0
192.168.0.0/16 is directly connected, Null0
 The routing table for R2 now contains the individual subnets for 172.30.0.0/16.
 Notice that a single summary route with two equal-cost paths no longer exists.
 Each subnet and mask has its own specific entry, along with the exit interface and
next-hop address to reach that subnet.
60
Verifying RIPv2 Updates
R1# show ip route
R
R
C
C
R
R
R
C
R
R
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.2.0/24 is directly connected, Loopback0
172.30.1.0/24 is directly connected, FastEthernet0/0
172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
192.168.0.0/16 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
 Fully converged routing tables.
61
Verifying RIPv2 Updates
R3# show ip route
C
C
R
R
C
C
C
R
R
R
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
172.30.200.32/28 is directly connected, Loopback2
172.30.200.16/28 is directly connected, Loopback1
172.30.2.0/24 [120/2] via 209.165.200.233, 00:00:01, Serial0/0/1
172.30.1.0/24 [120/2] via 209.165.200.233, 00:00:01, Serial0/0/1
172.30.100.0/24 is directly connected, FastEthernet0/0
172.30.110.0/24 is directly connected, Loopback0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 is directly connected, Serial0/0/1
209.165.200.228 [120/1] via 209.165.200.233, 00:00:02, Serial0/0/1
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 [120/1] via 209.165.200.233, 00:00:02, Serial0/0/1
192.168.0.0/16 [120/1] via 209.165.200.233, 00:00:02, Serial0/0/1
 Fully converged routing tables.
62
Verifying RIPv2 Updates
R2# debug ip rip
RIP: received v2 update from 209.165.200.234 on Serial0/0/1
172.30.100.0/24 via 0.0.0.0 in 1 hops
172.30.110.0/24 via 0.0.0.0 in 1 hops
172.30.200.16/28 via 0.0.0.0 in 1 hops
172.30.200.32/28 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0
(209.165.200.229)
RIP: build update entries
10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
192.168.0.0/16 via 0.0.0.0, metric 1, tag 0
209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
 Sending and receiving routing updates, which are individual routes with their
subnet mask instead of a single summary route with the classful mask.
63
Verifying RIPv2 Updates
R2# debug ip rip
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0
(209.165.200.229)
 Notice also that the updates are sent using the multicast address
224.0.0.9.
 RIPv1 sends updates as a broadcast 255.255.255.255.
 In general multicast updates:
 Take up less bandwidth on the network.
 Require less processing by devices that are not RIP enabled.
64
VLSM and CIDR
 RIPv2 and VLSM
 RIPv2 and CIDR
RIPv2 and VLSM
Added R4 for purposes of this discussion
 With RIPv2, R3 can now include all the 172.30.0.0 subnets in its
routing updates to R4
 This is because RIPv2 can include the proper subnet mask with the
network address in the update.
66
RIPv2 and VLSM
R3# debug ip rip
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0
(172.30.100.1)
RIP: build update entries
10.1.0.0/16 via 0.0.0.0, metric 2, tag 0
172.30.1.0/24 via 0.0.0.0, metric 3, tag 0
172.30.2.0/24 via 0.0.0.0, metric 3, tag 0
172.30.110.0/24 via 0.0.0.0, metric 1, tag 0
172.30.200.16/28 via 0.0.0.0, metric 1, tag 0
172.30.200.32/28 via 0.0.0.0, metric 1, tag 0
192.168.0.0/16 via 0.0.0.0, metric 2, tag 0
209.165.200.228/30 via 0.0.0.0, metric 2, tag 0
209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
67
RIPv2 and CIDR
R2(config)# ip route 192.168.0.0 255.255.0.0 Null0
 Supernets have masks that are smaller than the classful mask
(/16 here, instead of the classful /24).
 For the supernet to be included in a routing update, the routing
protocol must have the capability of carrying that mask.
 In other words, it must be a classless routing protocol, like RIPv2.
68
RIPv2 and CIDR
R2# debug ip rip
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0
(209.165.200.229)
RIP: build update entries
10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
192.168.0.0/16 via 0.0.0.0, metric 1, tag 0
209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
 CIDR supernet is included in the routing update sent by R2.
 Automatic summarization does not have to be disabled on RIPv2 or any
classless routing protocol for supernets to be included in the updates.
69
RIPv2 and CIDR
R1# show ip route
R
R
C
C
R
R
R
C
R
R
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.2.0/24 is directly connected, Loopback0
172.30.1.0/24 is directly connected, FastEthernet0/0
172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
192.168.0.0/16 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
 The routing table for R1 shows that it has received the supernet
route from R2.
 R1 applies the subnet mask that was sent in the routing update.
70
Verifying and Troubleshooting
RIPv2
 Verification and Troubleshooting Commands
 Common RIPv2 Issues
 Authentication
show ip route Command
R1# show ip route
R
R
C
C
R
R
R
C
R
R
172.30.0.0/16 is variably subnetted, 6 subnets, 2 masks
172.30.200.32/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.200.16/28 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.2.0/24 is directly connected, Loopback0
172.30.1.0/24 is directly connected, FastEthernet0/0
172.30.100.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
172.30.110.0/24 [120/2] via 209.165.200.229, 00:00:01, Serial0/0/0
209.165.200.0/30 is subnetted, 2 subnets
209.165.200.232 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
209.165.200.228 is directly connected, Serial0/0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
192.168.0.0/16 [120/1] via 209.165.200.229, 00:00:02, Serial0/0/0
 First command to use to check for network convergence.
 Important to look for the routes that you expect to be in the
routing table as well as for those that should not be in the
routing table.
72
show ip interface brief Command
R1# show ip interface brief
Interface
FastEthernet0/0
FastEthernet0/1
Serial0/0/0
Serial0/0/1
IP-Address
172.30.1.1
172.30.2.1
209.165.200.230
unassigned
OK?
YES
YES
YES
YES
Method
NVRAM
NVRAM
NVRAM
NVRAM
Status
up
up
up
down
Protocol
up
up
up
down
 If a network is missing from the routing table, it is often because
an interface is down or incorrectly configured.
 The show ip interface brief command quickly verifies the
status of all interfaces.
73
show ip protocols Command
R1# show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 29 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface
Send
Recv
Triggered RIP Key-chain
FastEthernet0/0
2
2
FastEthernet0/1
2
2
Serial0/0/0
2
2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.30.0.0
209.165.200.0
Routing Information Sources:
Gateway
Distance
Last Update
209.165.200.229
120
00:00:18
Distance: (default is 120)
 The show ip protocols command verifies several critical items,
including whether RIP is enabled, the version of RIP, the status of
automatic summarization, and the networks that were included in the
network statements.
74
debug ip rip Command
R2# debug ip rip
RIP: received v2 update from 209.165.200.234 on Serial0/0/1
172.30.100.0/24 via 0.0.0.0 in 1 hops
172.30.110.0/24 via 0.0.0.0 in 1 hops
172.30.200.16/28 via 0.0.0.0 in 1 hops
172.30.200.32/28 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.229)
RIP: build update entries
10.1.0.0/16 via 0.0.0.0, metric 1, tag 0
172.30.100.0/24 via 0.0.0.0, metric 2, tag 0
172.30.110.0/24 via 0.0.0.0, metric 2, tag 0
172.30.200.16/28 via 0.0.0.0, metric 2, tag 0
172.30.200.32/28 via 0.0.0.0, metric 2, tag 0
192.168.0.0/16 via 0.0.0.0, metric 1, tag 0
209.165.200.232/30 via 0.0.0.0, metric 1, tag 0
 debug ip rip is an excellent command to use to examine the contents of the routing
updates that are sent and received by a router.
 There can be times when a route is received by a router but is not added to the
routing table.
 One reason for this could be that a static route is also configured for the same
75
advertised network.
ping Command
R2# ping 172.30.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
R2# ping 172.30.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms
 An easy way to verify round-trip connectivity is with the ping
command
76
show running-config Command
R1# show running-config
!
hostname R1
!
interface FastEthernet0/0
ip address 172.30.1.1 255.255.255.0
!
interface FastEthernet0/1
ip address 172.30.2.1 255.255.255.0
!
interface Serial0/0/0
ip address 209.165.200.230 255.255.255.252
clock rate 64000
!
router rip
version 2
network 172.30.0.0
network 209.165.200.0
no auto-summary
!
<some output omitted for brevity>
77
Common RIPv2 Issues
 Version:
 Although RIPv1 and RIPv2 can be made compatible with additional
commands beyond the scope of this course, RIPv1 does not support
discontiguous subnets, VLSM, or CIDR supernet routes.
 network statements:
 Another source of problems might be incorrectly configured or
missing network statements configured with the network command.
 Remember, the network command does two things:
1. It enables the routing protocol to send and receive updates on any
local interfaces that belong to that network.
2. It includes the configured network in its routing updates to its
neighboring routers.
 A missing or incorrect network statement will result in missed routing
updates and routing updates not being sent or received on an interface.
 Automatic summarization:
 If there is a need or expectation for sending specific subnets and
not just summarized routes, make sure that automatic summarization
has been disabled with the no auto-summary command.
78
Authentication
 It is good practice to authenticate routing information.
 RIPv2, EIGRP, OSPF, IS-IS, and Border Gateway Protocol (BGP) can be
configured to encrypt and authenticate routing information.
 Hides the content of the routing information
 Routers will only accept routing information from other routers
that have been configured with the same password or
authentication information.
 Covered in CIS 83.
79
Topics
 RIPv1 Limitations
 RIPv1: Topology Limitations
 RIPv1: Discontiguous
Networks
 RIPv1: No VLSM Support
 RIPv1: No CIDR Support
 Configuring RIPv2
 Enabling and Verifying RIPv2
 Auto-Summary and RIPv2
 Disabling Auto-Summary in
RIPv2
 Verifying RIPv2 Updates
 VLSM and CIDR
 RIPv2 and VLSM
 RIPv2 and CIDR
 Verifying and Troubleshooting
RIPv2
 Verification and
Troubleshooting Commands
 Common RIPv2 Issues
 Authentication
80
Chapter 7
RIP version 2
CIS 82 Routing Protocols and Concepts
Rick Graziani
Cabrillo College
[email protected]
Last Updated: 4/7/2008