Transcript router rip

Sybex CCNA 640-802
Chapter 6: IP Routing
Instructor & Todd Lammle
Chapter 6 Objectives
• Understanding IP routing
• Static routing
• Dynamic routing
– RIP
– RIPv2
– Verifying routing
2
What is Routing?
To route a router need to know:
– Remote Networks
– Neighbor Routers
– All Possible routes to remote network
– The absolute best route to all remote
networks
– Maintain and verify the routing information
D
C
B
A
Basic Path Selection
What interface will the router send out a packet
if it has destination address of 10.10.10.18?
Simple IP Routing
>ping 172.16.1.2
172.16.2.0
172.16.1.0
172.16.3.1 172.16.3.2
e0
e0
172.16.2.2
Host A
172.16.2.1
A
B
s0
s0
B
172.16.1.1
172.16.1.2
Host B
Routing/PDU Example:
Host A Web browses to the HTTP
Server….
1. The destination address of a frame will be the
_______________________
2. The destination IP address of a packet will be the IP address of
the________________________________
3. The destination port number in a segment header will have a value
of __
Static Routes
Stub Network
172.16.1.0
172.16.2.0
SO
AA
172.16.3.1
SO
172.16.3.2
B
B
Routes must be unidirectional
Static Route Configuration
ip route remote network
[mask]
{address|interface}
[distance]
[permanent]
Router(config)#ip route remote_network mask next_hop
Static Route Example
Stub Network
172.16.2.0
172.16.1.0
SO
SO
A
172.16.3.1
172.16.3.2
ip route 172.16.1.0 255.255.255.0 172.16.3.2
or
ip route 172.16.1.0 255.255.255.0 s0
B
B
Default Routes
Stub Network
172.16.1.0
172.16.2.0
SO
SO
A
172.16.3.1
172.16.3.2
B
B
To send packets with a remote destination network not in the
routing table to the next-hop router, only used for stub networks.
ip route 0.0.0.0 0.0.0.0 172.16.3.1
ip classless
Routing Protocols
• Routing protocols are used
between routers to:
– Determine the path of a packet through a
network
– Maintain routing tables
– Two types: interior/exterior gateway
protocols (I/EGPs)
– Examples:
• IGP: RIP, IGRP;
• EGP: Border Gateway Protocol (BGP)
Routing Protocols
IGPs: RIP, IGRP
Autonomous System 1
EGPs: BGP
Autonomous System 2
• An autonomous system is a collection of networks
under a common administrative domain, i.e., all routers
sharing the same routing table are in the same AS.
• IGPs operate within an autonomous system.
• EGPs connect different autonomous systems.
Classful Routing Overview
Classful routing protocols do not
include the subnet mask with
the route advertisement.
– Within the same network, consistency of the
subnet masks is assumed.
– Summary routes are exchanged between
foreign networks.
– Examples of classful routing protocols:
• RIP Version 1 (RIPv1)
• IGRP
Classless Routing Overview
Classless routing protocols
include the subnet mask with
the route advertisement.
– Classless routing protocols support
variable-length subnet masking (VLSM).
– Summary routes can be manually
controlled within the network.
– Examples of classless routing protocols:
•
•
•
•
RIP Version 2 (RIPv2)
EIGRP
OSPF
IS-IS
Administrative Distance
Router B
Router A
RIP
Administrative
Distance=120
IGRP
Administrative
Distance=100
Router C
Default Administrative Distance
Directly Connected: 0
Static Route: 1
RIP: 120
IGRP: 100
EIGRP: 90
OSPF: 110
Router D
Distance Vector
Distance—How far
Vector—In which direction
D
Routing
Table
C
B
A
Routing
Table
Routing
Table
Routing
Table
All routers just broadcast their entire routing table out all
active interfaces on periodic time intervals
Distance vector algorithms do not allow a router to know the
exact topology of an internetwork.
Discovering Routes
Discovering Routes:
Converged Routing Tables
Routing Loops
Stop Router Loops
• Maximum hop count: RIP permits a hop
count of up to 15.
• Split horizon: routing information cannot
be sent back in the direction from which
it was received.
• Route poisoning: advertising the
downed network as unreachable
RIP Overview
64kbps
T1
T1
T1
–
–
–
–
Hop count metric selects the path, 16 is unreachable
Full route table broadcast every 30 seconds
Load balance maximum of 6 equal cost paths (default = 4)
RIPv2 supports VLSM and Discontiguous networks
RIP Routing Configuration
Router(config)#router rip
Router(config-router)#network network-number*
10.3.5.0
192.168.10.0
172.16.10.0
router RIP
router RIP
network 172.16.0.0
network 10.0.0.0
network 172.16.0.0
network 192.168.10.0
*Network is a classful network address.
Every device on network uses the same subnet mask
RIP Version 2
• Allows the use of variable length subnet
masks (VLSM) by sending subnet mask
information with each route update
• Distance Vector – same AD, and timers.
• Easy configuration, just add the
command “version 2” under the router
rip configuration
router rip
network 10.0.0.0
version 2
RIPv1 vs. RIPv2
RIPv1
Distance vector
Maximum hop count
15
Classful
Broadcast based
No support for VLSM
No authentication
No support for
discontiguous
networks
RIPv2
Distance vector
Maximum hop
count 15
Classless
Multicast 224.0.0.9
Supports VLSM
MD5 authentication
Supports
discontiguous
networks
Interior Gateway Routing Protocol
• Maximum hop count: 255 for larger
network, default 100
• Composite metric: bandwidth and delay
of the line.
Config t
router igrp 10
IGRP vs. RIP
Large network
Uses AS number
for activation
Small network
Uses network address,
with all subnet and
host bits off
Full route table
Full route table update
update per 90 sec per 30 sec
AD 100
AD 120
Uses bandwidth Uses only hop count to
and delay of the determine the best
line as metric,
path to a remote
maximum hop
network, max 15
count 255
Discontiguous Addressing
• Two networks of the same classful networks
are separated by a different network address
192.168.10.0/24
192.168.10.0/24
10.1.1.0/24
– RIPv1 and IGRP do not advertise subnet masks, and therefore
cannot support discontiguous subnets.
– OSPF, EIGRP, and RIPv2 can advertise subnet masks, and
therefore can support discontiguous subnets.
Passive Interface
Maybe you don’t want to send RIP updates
out your router interface connected to the
Internet. Use the passive-interface
command:
Router(config)#router rip
Router(config-router)#passive-interface
serial0
Internet
X
S0
Updates
Gateway
This allows a router to receive route updates on an interface,
but not send updates via that interface
Verifying RIP
Router#show ip protocols
Router#show ip route
Router#debug ip rip
Router#undebug all (un all)
Summary
– Open your books and go through all the
written labs and the review questions.
– Review the answers in class.
30