Layer 2 Data Link Frame

Download Report

Transcript Layer 2 Data Link Frame

Chapter 1
Introduction to Routing and
Packet Forwarding
CIS 82 Routing Protocols and Concepts
Rick Graziani
Cabrillo College
[email protected]
Spring 2010
This Presentation
 For detailed information see the notes section within this
PowerPoint.
 This presentation is based on the Exploration course/book, Routing
Protocols and Concepts.
 Notes section may contain additional details
 For a copy of this presentation and access to my web site for other
CCNA, CCNP, and Wireless resources please email me for a
username and password.
 Email: [email protected]
 Web Site: www.cabrillo.edu/~rgraziani
2
Note
 This chapter contains mostly introductory material.
 Most of not all of this information will be explained in more detail
in later chapters or later courses.
 The bootup process and the IOS are examined in a later
course.
 Do not worry or focus too much on the details for now.
 This will all be examined and explained in the following chapters.
3
For further information
 This presentation is an
overview of what is
covered in the
curriculum/book.
 For further explanation
and details, please read
the chapter/curriculum.
 Book:
 Routing Protocols
and Concepts
 By Rick Graziani and
Allan Johnson
 ISBN: 1-58713-206-0
 ISBN-13: 978-58713206-3
4
Topics


Inside the Router
 Routers are computers
 Router CPU and Memory
 Internetwork Operating
System
 Router Bootup Process
 Router Ports and Interfaces
 Routers and the Network
Layer
Path Determination and
Switching Function
 Packet Fields and Frame
Formats
 Best Path and Metrics
 Equal Cost Load Balancing
 Path Determination
 Switching Function


CLI Configuration and Addressing
 Implementing Basic
Addressing Schemes
 Basic Router Configuration
Building the Routing Table
 Introducing the Routing
Table
 Directly Connected
Networks
 Static Routing
 Dynamic Routing
 Routing Table Principles
5
Inside the Router
 Routers are computers
 Router CPU and Memory
 Internetwork Operating System
 Router Bootup Process
 Router Ports and Interfaces
 Routers and the Network Layer
Routers are Computers
Leonard Kleinrock and the first IMP.
 A router is a computer:
 The first router (ARPANET):
 IMP (Interface Message Processor)
 Honeywell 516 minicomputer
 August 30, 1969.
7
Router physical characteristics
8
 Routers forwarding packets (packet switching):
 From the original source to the final destination.
 Selects best path
 A router connects multiple networks:
 Interfaces on different IP networks
9
 Router interfaces:
 LAN
 WAN
10
Routers Determine the Best Path
 The router’s primary responsibility:
 Determining the best path
 Forwarding packets toward their destination
11
Routers Determine the Best Path
IP Packet enters router’s Ethernet interface.
Router examines the packet’s destination IP address.
Router searches for a best match between packet’s destination IP address and
network address in routing table.
Using the exit-interface in the route, the packet is forwarded to the next router or
the final destination.
 Routing table
 Determines best path.
 Best match between destination IP address and network
address in routing table
12
Router
CPU and
Memory
 CPU - Executes operating system instructions
 Random access memory (RAM)
 running copy of configuration file
 routing table
 ARP cache
 Read-only memory (ROM)
 Diagnostic software used when router is powered up.
 Router’s bootstrap program
 Scaled down version of operating system IOS
 Non-volatile RAM (NVRAM)
 Stores startup configuration. (including IP addresses, Routing protocol)
 Flash memory - Contains the operating system (Cisco IOS)
 Interfaces - There exist multiple physical interfaces that are used to connect
network. Examples of interface types:
 Ethernet / fast Ethernet interfaces
 Serial interfaces
 Management interfaces
13
Cisco IOS - Internetwork
Operating System
 Many different IOS images.
 An IOS image is a file that contains the entire IOS for that router.
 IOS features
 Example IPv6 or a routing protocol such as Intermediate
System–to–Intermediate System (IS-IS).
14
Router Bootup Process (more in later course)
15
Bootup Process
running-config
IOS (running)
startup-config
IOS
Bootup program
ios (partial)
16
Where is the permanent configuration file stored used during boot-up?
NVRAM (B)
Where is the diagnostics software stored executed by hardware modules? ROM (D)
Where is the backup (partial) copy of the IOS stored?
ROM (D)
Where is IOS permanently stored before it is copied into RAM?
FLASH (C)
Where are all changes to the configuration immediately stored?
RAM (A)
A
running-config
IOS (running)
B
startup-config
C
IOS
D
Bootup program
ios (partial)
17
?
?
?
?
?
?
?
running-config
IOS (running)
startup-config
IOS
Bootup program
ios (partial)
18
startup-config
IOS
C
A
running-config
IOS (running)
B
running-config
ios (partial)
B
startup-config
A
D
C
IOS
Bootup program
IOS (running)
D
A
D
Bootup program
ios (partial)
19
Router Boot Process –
Details (later)
1. ROM
1. POST
2. Bootstrap code executed
3. Check Configuration Register value (NVRAM)
0 = ROM Monitor mode
1 = ROM IOS
2 - 15 = startup-config in NVRAM
2. Check for IOS boot system commands in startup-config file (NVRAM)
If boot system commands in startup-config
a. Run boot system commands in order they appear in startup-config to locate the IOS
b If boot system commands fail, use default fallback sequence to locate the IOS (Flash, TFTP, ROM)
3. Locate and load IOS, Default fallback sequence: No IOS boot system commands in startup-config
a. Flash (sequential)
b. TFTP server (netboot) - The router uses the configuration register value to form a filename from
which to boot a default system image stored on a network server.
c. ROM (partial IOS) or keep retrying TFTP depending upon router model
- If no IOS located, get partial IOS version from ROM
4. Locate and load startup-config configuration
a. If startup-config found, copy to running-config
b. If startup-config not found, prompt for setup-mode
c. If setup-mode bypassed, create a “skeleton” default running-config (no startup-config)
20
Verify the router boot-up process
 show version command is used to view information about the
router during the bootup process (later).
21
Ports and Interfaces
 Port - management ports used for administrative access
 Interface - capable of sending and receiving user traffic.
 Note: However, these terms are often used interchangeably.
22
Management
Ports
Console port
 Terminal
 PC running terminal emulator software
 No need for network access
 Used for initial configuration
Auxiliary (AUX) port
 Not all routers have auxiliary ports.
 At times, can be used similarly to a console port
 Can also be used to attach a modem.
 Note: Auxiliary ports will not be used in this curriculum.
23
Router Interfaces
 Interfaces - Receive and forward packets.
 Various types of networks
 Different types of media and connectors.
 Different types of interfaces.
 Fast Ethernet interfaces - LANs
 Serial interfaces - WAN connections including T1, DSL, and ISDN
24
Router Interfaces
FastEthernet 0/0
MAC: 0c00-41cc-ae12
10.1.0.1/16
FastEthernet 0/0
MAC: 0c00-3a44-190a
192.168.1.1/24
Serial 0/0
172.16.1.1/24
Serial 0/1
172.16.1.2/24
 Router Interface:
 Different network
 IP address and subnet mask of that network
 Cisco IOS will not allow two active interfaces on the same
router to belong to the same network.
25
LAN Interfaces
 Ethernet and Fast Ethernet interfaces
 Connects the router to the LAN
 Layer 2 MAC address
 Participates in the Ethernet
 Address Resolution Protocol (ARP):
 Maintains ARP cache for that interface
 Sends ARP requests when needed
 Responds with ARP replies when required
 Typically an RJ-45 jack (UTP).
 Router to switch: straight-through cable
 Router to router: crossover cable
26
WAN Interfaces
 Point-to-Point, ISDN, and Frame Relay interfaces
 Connects routers to external networks.
 The Layer 2 encapsulation can be different types including:
 PPP
 Frame Relay
 HDLC (High-Level Data Link Control).
 Note: MAC addresses are used only on Ethernet interfaces and are
not on WAN interfaces.
 Layer 2 WAN encapsulation types and addresses are covered in a
later course.
27
Routers at
the
Network
Layer
 Layer 3 device because its primary forwarding
decision is based on the information in the Layer 3 IP
packet (destination IP address).
 This is known as routing.
28
Routers Operate at Layers 1, 2, and 3
29
Path Determination and
Switching Functions
Ethernet Frame
IPv4 (Internet
Protocol)
 Layer 2 addresses: Addressing PC/Router-to-PC/Router within a
network
 Layer 3 addresses:
 Original source layer 3 address (IP) to final destination layer 3
address (IP)
 Does not change (unless NAT is used)
31
Best Path
Which is path is
my “best path”?
RIP’s metric is hop count
OSPF’s metric is
bandwidth
?
 Router’s determine best-path to a network:
 Depends on the routing protocol
 A protocol used to between routers to determine “best path”
 Routing protocols use their own rules and metrics.
 A metric:
 Quantitative value used to measure the distance to a given route.
 Best path:
 Path with the lowest metric.
32
To reach the 192.168.1.0/24
network it is 2 hops via R2 and 2
hops via R4.
Equal Cost
Load
Balancing
?
?
192.168.1.0/24
What happens if a routing table has two or
more paths with the same metric to the same
destination network? (equal-cost metric)
Router will perform equal-cost load balancing.
33
Equal-Cost Paths
Versus UnequalCost Paths
? T1
?
T3
192.168.1.0/24
Can a router use multiple paths if the paths
(cost, metric) to reach the destination
network are not equal?
EIGRP routing protocol which supports unequal
cost load balancing
34
Packet Forwarding
Packet forwarding involves two functions:
1. Path determination function
2. Switching function
35
Path Determination
Router receives packet.
Destination IP address matches a network on one
of its directly connected networks.
Packet is forwarded out
that network.
Directly connected
network
 Path determination function is the process of how the router determines
which path to use when forwarding a packet.
 Router searches its routing table for match with packet’s destination
IP address.
 One of three path determinations results from this search:
 Directly connected network
 Remote network
 No route determined
36
Path Determination
Router receives packet.
Destination IP address matches a remote network
which can only be reached via another router.
Packet is forwarded out that
network to the next-hop router.
Remote
network
37
Path Determination
Router receives packet.
Destination IP address does NOT match any
network in the router’s routing table.
Packet is dropped.
No route determined
Does this mean the network does not
exist?
No, only that the router does not know
about that network. (later)
38
Packet Forwarding: Switching Function
 Switching function is the process used by a router to:
 Accept a packet on one interface and
 Forward it out another interface
 Encapsulate the packet in the appropriate data-link frame type for
the outgoing data link.
39
192.168.4.10
Path
Forwarding
192.168.1.10
Layer 2 Data Link Frame
Dest. MAC
0B-31
00-10
Source MAC
00-20
0A-10
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
What does a router do with a packet received from one network and destined for another
network?
1. Decapsulates the Layer 3 packet by removing the Layer 2 frame header and trailer
2. Examines the destination IP address of the IP packet to find the best path in the
routing table
3. Encapsulates the Layer 3 packet into a new Layer 2 frame and forwards the frame
out the exit interface
40
Remember: Encapsulation
These addresses
do not change!
Layer 3 IP Packet
These change from
host to router, router to
router, and router to
host.
Destination IP
Address
Source IP
Address
Other IP
fields
Data
Layer 2 Data Link Frame
Destination
Address
Next hop Data
Link Address of
Host or Router’s
interface

Source
Address
Type
Data
Trailer
Current Data Link
Address of Host or
Router’s exit interface
Now, let’s do an example…
41
Layer 2 Data Link Frame
Dest.
Dest.Add
MAC
MAC
0B-31
FF-FF
00-10
Source Add
MAC
0A-10
00-20
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
 This is just a summary.
 The details will be shown next!
 Now for the details…
42
Layer 2 Data Link Frame
Dest. MAC
00-10
Source MAC
0A-10
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
43
Layer 2 Data Link Frame
Dest. MAC
0B-31
00-10
Source
Source MAC
MAC
00-20
0A-10
Layer 3 IP Packet
Type
Type
800
800
RTA ARP Cache
IP Address
MAC Address
192.168.2.2
0B-31
Dest. IP
192.168.4.10
Source IP
192.168.1.10
Network
192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
192.168.4.0/24
IP
fields
Data
Trailer
Trailer
RTA Routing Table
Hops Next-hop-ip Exit-interface
0
Dir.Conn.
e0
0
Dir.Conn
e1
1
192.168.2.2
e1
2
192.168.2.2
e1
44
Layer 2 Data Link Frame
Dest. Add
MAC
FF-FF
0B-31
Source Add
MAC
00-20
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
Network
192.168.1.0/24
192.168.2.0/24
192.168.3.0/24
192.168.4.0/24
IP
fields
Data
Trailer
RTB Routing Table
Hops Next-hop-ip Exit-interface
1
192.168.2.1
e0
0
Dir.Conn
e0
0
Dir.Conn
s0
1
192.168.3.2
s0
45
Layer 2 Data Link Frame
Dest.
Dest.Add
MAC
FF-FF
0B-20
Source
SourceAdd
MAC
0C-22
Layer 3 IP Packet
Type
Type
800
800
RTC ARP Cache
IP Address
MAC Address
192.168.4.10
0B-20
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
RTC Routing Table
Network
Hops Next-hop-ip Exit-interface
192.168.1.0/24 2
192.168.3.1
s0
192.168.2.0/24 1
192.168.3.1
s0
192.168.3.0/24 0
Dir.Conn
s0
192.168.4.0/24 0
Dir.Conn
e0
46
Layer 2 Data Link Frame
Dest. MAC
0B-20
Source MAC
0C-22
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
47
Layer 2 Data Link Frame
Dest.
Dest.Add
MAC
MAC
0B-31
FF-FF
00-10
Source Add
MAC
0A-10
00-20
Layer 3 IP Packet
Type
800
Dest. IP
192.168.4.10
Source IP
192.168.1.10
IP
fields
Data
Trailer
 The summary once again!
48
CLI Configuration and Addressing
Before we begin:
 Download: Packet Tracer File:
 http://netacad.cabrillo.edu/curricul
um/graziani/cis82/labs-e2/e2-1-52.pkt
 Download and Install Packet Tracer
you have not done so already:
 http://www.cabrillo.edu/~rgraziani/
courses/cis81.html
 Download Lab:
 http://netacad.cabrillo.edu/curricul
um/graziani/cis82/labse2/en_ERouting_ILM_v4050.pdf
49
Hands-on Labs
Networking Lab: Room 2504 and CTC
Check-out Pods
NetLab
Packet Tracer (Not for homework)
50
Establishing a HyperTerminal session (next week)
Router
Console port
Rollover cable
Terminal or a
PC with
terminal
emulation
software
Com1 or Com2 serial port
Take the following steps to connect a terminal to the console port on the router:
 Connect the terminal using the RJ-45 to RJ-45 rollover cable and an RJ-45 to DB-9
or RJ-45 to DB-25 adapter.
 Configure the terminal or PC terminal emulation software for 9600 baud, 8 data bits,
no parity, 1 stop bit, and no flow control.
51
Establishing a Terminal session
 Tera Term
 HyperTerminal (comes with Windows)
 Putty
=
 Important: A console connection is not the same as a network
connection!
52
When do you need to use a console connection to the router?
When there is not a network connection to the router (can’t use telnet).
What software do you need?
Tera Term, HyperTerminal, Putty, etc.
What cable and ports do you use?
PC: Serial port & Router: Console Port
Rollover or Console Cable
Terminal Connection
No network connection needed
Console Port
Serial
53
C:\> ping
C:\> telnet
Ethernet Connection
Network connection needed
NIC
When can you use a network connection to
the router? When there is a network connection to the
What
What
router (telnet).
software/command do you need? TCP/IP, Terminal prompt (DOS),
Tera Term, etc.
cable and ports do you use? PC & Router: Ethernet NIC
Ethernet straight-through cable
When should you not use a network
connection to configure the router?
When the change may
disconnect the telnet connection.
54
C:\> ping
C:\> telnet
Ethernet Connection
Network connection needed
NIC
Terminal Connection
No network connection needed
Console Port
Serial
55
Serial Connectors
Smart
Serial
“Older”
Serial
 2500 have the “older,” larger serial interfaces
 Later Cisco routers use the smart serial interfaces which allows
more data to be forwarded across fewer cable pins.
56
Serial Cables
DCE Cable DTE Cable
 Router is typically a DTE device.
 The DTE cable is connected to the serial interface
on the router to a CSU/DSU device (DCE).
DCE Side
DTE Side
57
WAN Interface Configuration
R1(config)# interface Serial0/0
R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# description Link to R2
R1(config-if)# clock rate 64000 DCE Only
R1(config-if)# no shutdown
58
Let’s do Lab 1.5.2 using Packet Tracer


Download: Packet Tracer File:
 http://netacad.cabrillo.edu/curriculum/graziani/cis82/labs-e2/e2-1-5-2.pkt
Download Lab:
 http://netacad.cabrillo.edu/curriculum/graziani/cis82/labs-e2/E2_Lab_1_5_2_cabrillo.doc
59
Your Interfaces may differ
R1# show ip interface brief
Interface
FastEthernet0/0
FastEthernet0/1
Serial0/0
Serial0/1
IP-Address
OK?
192.168.1.1
192.168.1.2
192.168.2.1
unassigned
Method Status Protocol
YES
YES
YES
YES
manual
manual
manual
manual
up
up
up
up
up
up
up
up
FastEthernet 0 = FastEthernet 0/0
FastEthernet 1 = FastEthernet 0/1 = FastEthernet 1/0
Serial 0 = Serial 0/0 = Serial 0/0/0
Serial 1 = Serial 0/1 = Serial 0/0/1
60
Command Overview (partial list from lab)
Router>
Router> enable
Router#
Router# configure terminal
Router(config)# exit
Router# config t
user mode
privilege mode
Router(config)# hostname name
Router(config)# enable secret password
Router(config)# line console 0
Router(config-line)# password password
Router(config-line)# login
Router(config)# line vty 0 4
Router(config-line)# password password
Router(config-line)# login
privilege password
console password
Router(config)# banner motd # message #
banner
Router(config)# interface type number
Router(config-if)# ip address address mask
Router(config-if)# description description
Router(config-if)# no shutdown
configure interface
telnet password
61
Other Commands
Router# copy running-config startup-config
Router#
Router#
Router#
Router#
show
show
show
show
running-config
ip route
ip interface brief
interfaces
62
Different Modes
Router# hostname R1
^
% Invalid input detected at '^' marker.
Router# configure terminal
Router(config)# hostname R1
R1(config)#
 IOS commands must be entered in the correct mode.
63
Serial Connectors
Smart
Serial
“Older”
Serial
 2500 have the “older,” larger serial interfaces
 Later Cisco routers use the smart serial interfaces which allows
more data to be forwarded across fewer cable pins.
64
Serial Connectors
DCE Cable
DTE Cable
 Router is typically a DTE device.
 The DTE cable is connected to the serial interface on the router to a
CSU/DSU device (DCE).
65
WAN Interface Configuration
R1(config)# interface Serial0/0
R1(config-if)# ip address 192.168.2.1 255.255.255.0
R1(config-if)# description Link to R2
R1(config-if)# clock rate 64000 DCE Only
R1(config-if)# no shutdown
66
Unsolicited Messages from IOS
R1(config)# interface fastethernet0/0
R1(config-if)# ip address 172.16.3.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# descri
*Mar 1 01:16:08.212: %LINK-3-UPDOWN: Interface
FastEthernet0/0, changed state to up
*Mar 1 01:16:09.214: %LINEPROTO-5-UPDOWN: Line protocol on
Interface
FastEthernet0/0, changed state to upption
R1(config-if)#
 The IOS often sends unsolicited messages
 Does not affect the command
 Can cause you to lose your place when typing.
67
Unsolicited Messages from IOS
R1(config)# line console 0
R1(config-line)# logging synchronous
R1(config-if)# descri
*Mar 1 01:28:04.242: %LINK-3-UPDOWN: Interface
FastEthernet0/0, changed state to up
*Mar 1 01:28:05.243: %LINEPROTO-5-UPDOWN: Line protocol on
Interface
FastEthernet0/0, changed state to up
R1(config-if)# description
 To keep the unsolicited output separate from your input, enter line
configuration mode for the console port and add the logging
synchronous
68
LAN Interface Configuration
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# description R1 LAN
R1(config-if)# no shutdown
Fa0/1
69
Each Interface Belongs to a Different Network
R1(config)# interface FastEthernet0/1
R1(config-if)# ip address 192.168.1.2 255.255.255.0
192.168.1.0 overlaps with FastEthernet0/0
R1(config-if)# no shutdown
192.168.1.0 overlaps with FastEthernet0/0
FastEthernet0/1: incorrect IP address assignment
192.168.1.1/24
Fa0/1
192.168.1.2/24
Same Network!
70
Each Interface Belongs to a Different Network
R1# show ip interface brief
Interface
IP-Address
FastEthernet0/0
192.168.1.1
Serial0/0
192.168.2.1
FastEthernet0/1
192.168.1.2
OK?
YES
YES
YES
Serial0/1
YES
unassigned
Method
manual
manual
manual
Status Protocol
up
up
up
up
administratively
down down
unset administratively
down down
Fa0/1
71
Verifying Interfaces
R1# show interfaces
<some interfaces not shown>
FastEthernet0/0 is up, line protocol is up (connected)
Hardware is Lance, address is 0007.eca7.1511 (bia 00e0.f7e4.e47e)
Description: R1 LAN
Internet address is 192.168.1.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00,
Last input 00:00:08, output 00:00:05, output hang never
Last clearing of “show interface” counters never
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
<output omitted>
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Description: Link to R2
Internet address is 192.168.2.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
<output omitted>
72
Verify Router Configuration
R1# show running-config
!
version 12.3
!
hostname R1
!
interface FastEthernet0/0
description R1 LAN
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
description Link to R2
ip address 192.168.2.1 255.255.255.0
clock rate 64000
!
banner motd ^C
******************************************
WARNING!! Unauthorized Access Prohibited!!
******************************************
^C
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
!
end
Note: shutdown is the
default. no shutdown does
not show in the configuration.
73
Save Configuration
R1# copy running-config startup-config
R1# show startup-config
Using 728 bytes
!
version 12.3
!
hostname R1
!
interface FastEthernet0/0
description R1 LAN
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
description Link to R2
ip address 192.168.2.1 255.255.255.0
clock rate 64000
!
banner motd ^C
******************************************
WARNING!! Unauthorized Access Prohibited!!
******************************************
^C
line con 0
password cisco
login
line vty 0 4
password cisco
login
!
end
74
Building the Routing Table
 Introducing the Routing Table
 Directly Connected Networks
Show Routing Table
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C
C
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
76
Introducing the Routing Table
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C
C
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
 Routing table is a data file in RAM that is used to store route
information about:
 Directly connected networks
 Remote networks
77
Introducing the Routing Table
R1# show ip route
<output omitted>
C
C
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
Exit Interfaces
 Directly connected interfaces contain the exit interface (more later)
78
Introducing the Routing Table
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
<output omitted>
C
C
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
Directly Connected
Networks
 directly connected network is a network that is directly attached to one of
the router interfaces.
 When a router’s interface is configured with an IP address and subnet
mask, the interface becomes a host on that attached network.
 Active directly connected networks are added to the routing table.
79
Introducing the Routing Table
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
<output omitted>
C
C
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 is directly connected, Serial0/0
Remote Network
 A remote network is a network that is not directly connected to the
router.
 A remote network is a network that can only be reached by sending
the packet to another router.
 Remote networks are added to the routing table using: (later)
 Dynamic routing protocol
 Static routes
80
Using NetLab
81
NetLab
Basic Router
Pod
82
Chapter 1
Introduction to Routing and
Packet Forwarding
CIS 82 Routing Protocols and Concepts
Rick Graziani
Cabrillo College
[email protected]